Symptom
Failed to call into Yeastar PBX.
Common Causes
Firstly you would need to know how to get the BRI/PRI packets.
U-Series/Gateway: BRI/PRI debug for U-Series
S-Series: BRI/PRI debug for S-Series
For S-Series, you can also try System Log with PRI debug option enabled: System Log
Then you need to understand the BRI/PRI call flow and a few elements in Q.931 messages by followed this article: A Brief View of the PRI Call Flow
1. Incorrect DID settings
Sometime the provider doesn't send a line number as DID number in the incoming SETUP message. It could be a short number like extension number or so.
Whatever, you can find out the real DID number in the incoming SETUP messages.
See the header "Called Party Number" which presents the DID number the provider sends.
< Message Type: SETUP (5)
< [04 03 90 90 a3]
< Bearer Capability (len= 5) [ Ext: 1 Coding-Std: 0 Info transfer capability: 3.1kHz audio (16)
< Ext: 1 Trans mode/rate: 64kbps, circuit-mode (16)
< User information layer 1: A-Law (35)
< [18 03 a9 83 82]
< Channel ID (len= 5) [ Ext: 1 IntID: Implicit Other(PRI) Spare: 0 Exclusive Dchan: 0
< ChanSel: As indicated in following octets
< Ext: 1 Coding: 0 Number Specified Channel Type: 3
< Ext: 1 Channel: 2 Type: CPE]
< [1e 02 82 88]
< Progress Indicator (len= 4) [ Ext: 1 Coding: CCITT (ITU) standard (0) 0: 0 Location: Public network serving the local user (2)
< Ext: 1 Progress Description: Inband information or appropriate pattern now available. (8) ]
< [6c 0d 41 83 31 33 35 30 31 38 33 36 38 36 35]
< Calling Party Number (len=15) [ Ext: 0 TON: Subscriber Number (4) NPI: ISDN/Telephony Numbering Plan (E.164/E.163) (1)
< Presentation: Presentation allowed, Network provided (3) '13501836865' ]
< [70 09 c1 35 31 30 36 34 32 37 36]
< Called Party Number (len=11) [ Ext: 1 TON: Subscriber Number (4) NPI: ISDN/Telephony Numbering Plan (E.164/E.163) (1) '51064276' ]
2. Overlap-dial Mode
You can refer this guide to fix the issue.
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