Fanvil IP Phone Shows "Upgrade Failed!" Periodically

Applicability

  • PBX Model:  S-Series
  • Firmware version: 30.13.0.X

 

Symptom

Fanvil IP phone shows "Upgrade Failed!" periodically which is annoying. For example:

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Cause

The Fanvil IP tries to download the phonebook "fanvil.xml" from PBX which doesn't exist. Then the IP shows improper error "Upgrade Failed!"

 

Solution

Upload the Auto Provisioning app package in the PBX App Center:  http://help.yeastar.com/download/support/autoprovision-s_series-1.8.28.2.tar

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Later re-provision the Fanvil IP phone.

1. If you didn't use a template to provision.

Edit the device to untick the Local Phone Book option. Then reboot the IP phone.

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2. If you used a template to provision.

Edit the template and untick the Local Phone Book option.

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Then go back to the device list. Re-select the template for the device you need to fix. Click Save and reboot the IP phone.

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