uaCSTA enabled after autoprovision - outbound call failure

First time user of Yeastar IP PBX and am  setting up new S20 with Fanvil X5U and X6U handsets. Early on used default autoprovisioning fanvil  template after configuration wizard added sip trunk and added one extension to one handset. Changed inbound diversion from IVR to extension.  Tested inbound calls and outbound calls. These worked fine. Then updated S20 FW to - reset desktop phone and re-autoprovisioned with default fanvil template. Outbound routing was default. Outbound calls gave "Internal error" Please hangup" on desk phone. Phone device log showed "Line not found".

Consulted support docs


but nothing there that I could use to correct situation.

To debug reset PBX and desk phone  ran thru PBX configuration wizard and this time manually registered handset to PBX and calls outbound worked. Compared Xml phone configurations between working and non working setup and noticed that uaCSTA was not enabled in the working setp.

read further about setting up uaCSTA for Fanvil phones


seemed to be provisioned with the correct settings.

I gather uaCSTA would be necessary if  the Linkus client is used. In previous PBX GUI's there appeared to be a uaCSTA setting to enable/disable in General/Sip/Advanced - this doesn't seem to be there now? Currently have disabled uaCSTA on the desk phone menu.

Should I be able to use the uaCSTA enabled line to call out after autoprovisioning with default template? (seemed to work when I was on previous FW)?

Thanks for advice.


Please sign in to leave a comment.