0

Linkus remote extension gives 404 when dialing out

Setup:

Yeastar S50
Dual mode Default interface WAN
local WAN IP 192.168.1.9 
local LAN IP 10.10.248.222
SIP trunk IP: 145.131.159.179, registered via LAN by using static rule
local phones are connected via 10.10.248.0 network 
WAN IP 123.456.789 (Not real IP ofcourse)

NAT settings (On PBX) : External IP: 123.456.789 
local: 145.131.159.179
local: 10.10.248.222
local: 192.168.1.9 

Custom settings in App:
192.168.1.9
8111
123.456.789
8111

Local phones are working correctly when dialing out, SIP trunk is registered, that's all ok.

A user wants to use a remote extension by using Linkus.
Ports are opened, remote login is ticked. Remote login is working, App is working. 

Now when the remote user dials any number it says "You have dialed a wrong number. In the logging i see "404 not found"

I got the feeling that the call is not transferred to the (working) SIP trunk.
Coud that be a NAT problem or do I need to do change something in the headers? It worked at some point (without audio) so I changed NAT settings and now it just says "You have dialed a wrong number" (In the App) and 404 not found in the debug.  Can't find what to do.


2 comments

Please sign in to leave a comment.