Prompt instead of busy signal from MyPBX when using BriTrunks

We have MyPBX-Standard V4 with firmware. MyPBX is connected to ISDN-PBX through two BRI modules (four BriTrunks). External inbound calls from SIP trunks are routed to outbound routes for BriTrunks. This works well for up to 8 simultaneous calls to different numbers.


However, when there are two simultaneous calls to the same number routed to ISDN-PBX, ISDN-PBX pick up the first call and send busy signal to the second call. MyPBX treats the second call as from outbound and uses options that are defined in Internal Settings/Options. This means that MyPBX pick up the second call and plays Busy Line Prompt. We hate this behavior because caller is charged for just information that line is busy. Anybody can identify busy signal and nobody wants to pay for the same information that is played by automated voice. We would like to set MyPBX to send busy signal to SIP trunks so that caller hears busy tone and he/she is not charged for a call. When we change Busy Line Prompt to nothing (it is possible), MyPBX pick up the second call anyway and plays the Default Prompt instead. Please advice how to set up MyPBX to resend busy line signal to SIP trunks without playing any prompt and more importantly, without picking up the call so that call is free of charge. Thanks.


Please sign in to leave a comment.