0

Issues with private trunk on WAN

I’m having problems configuring a private trunk with my Yeastar S50. I’ve configured the S50 with an online sip provider with 1 phone without problems. Both inbound and outbound calls work perfect.  Now I wanted to add my ISP private trunk but can’t seems to get it working completely.

Private trunk info
Gateway  172.17.4.89
PBX IP  172.17.4.90
Subnet  255.255.255.248 /29

Media 172.17.2.10
SIP 172.17.2.15

So, at this point what I did once the S50 was working fine with my first online SIP, I enabled mode to dual and configured my WAN interface. Next, I added a static route for 172.17.2.0/255.255.255.0 to the WAN port.

The S50 registers with my ISP but when I make a call, my ISP side rejects my invite because the from URI is wrong and contains the IP of the SIP server instead the IP assigned for my PBX system. I’ve included 2 packets provided by my ISP. First one if the one with the wrong info and the second is one from my existing FreePBX system that is working.

 

Any idea why I am not sending my own IP in the From invite?

5 comments

Please sign in to leave a comment.