Strange problem with Cisco CP-8845-3PCC and Yeastar S50

Hi All,

I Hope someone can help me with a strange problem. I recently buy a Cisco CP-8845-3PCC Phone as a replacement for the CP-7970G. The problem was, working from home; don't wanna have 2 phone's on my desk. The CP-7970G only could connect to 1 PBX, and for that reason I had an extra Linksys SPA942 on my desk with the lines from work. In the living room I have a SPA962 with 2 home lines, 1 work line, both work fine.

The technical details:

At Home: RasPBX (with 2 lines)
At Work: Yeastar S50 (Multiple lines) (I have 2 at home extension)
Cisco CP-8845-3PCC (Firmware: 11-3-2MPP0001) (Have try all versions) (Multiplatform you can compare it with the SPA series with web interface).

VPN site to site Connection between home and work, at work I have permission to the Voip Lan to connect to the Yeastar. At home I have a seperate VLAN for all Voip. Everything works fine, I can call with both SPA942 and 962 accept the CP-8845-3PCC.

I have followed the instructions of:

All phones have the same settings (accept the 8845 have more than the older ones but leave it to default.) I only work with IPv4, disabled IPv6 on the phone.

On the Cisco CP-8845-3PCC all the lines register, 2 from home, 2 from work. People can call me from work, from outside, no problem, but I can't call out with the work lines. The home lines work perfectly but the work lines doesn't.

-All phones same network permissions at home
-All SPAxxx phones work perfectly, local and tru VPN s2s to work
-The CP-8845-3PCC register (green LED)
-The CP-8845-3PCC can receive incoming calls from work (tru VPN), with voice both directions, perfect quality. 
-The CP-8845-3PCC work lines doesn't work If I want to call out, not to an extension at work or a mobile phone.
-The CP-8845-3PCC works perfect with home extensions
-If I apply the dialplan of Yealink "[x.]" or the one from the SPA962/42 both doesn't work If I want to call out.

Am I missing something? Can anyone help me, thank you!


Please sign in to leave a comment.