[Issue Description]
The Companyflex sip trunk was working fine on your PBX, but recently when you make outgoing calls through the SIP trunk, then received '403 Forbidden' from the SIP provider.
[Applicable Models]
Yeastar S-series PBX
[Cause]
SIP provider did some changes on their side probably after 2022, June.
1. They request the INVITE 'Contact' header should be the SIP trunk Username,
2. They request the INVITE should include 'P Asserted Identity' with the SIP trunk DOD number.
[Solution]
1. Please upgrade the S-series PBX firmware.
a. For S-series V2, please upgrade to 30.15.0.164, then download click to download -> pbxcenter-s_series-1.21.1-0.155.1.tar and upload it to the PBX App Center->Upload page
After uploading the file, it needs to wait for a few minutes for installation, please wait for a few minutes, until you get the App Installed message, then click on OK.
b. For S-series V4, please upgrade to 65.16.0.164, then download click to download -> pbxcenter-s_series_v4-65.5.1-0.155.1.tar and upload it to the PBX App Center->Upload page (Installation step same as step a)
c. For S-series V5(S50i), please upgrade to 78.16.0.32, then download click to download -> pbxcenter-s_series_v5-78.3.4-0.1.tar and upload it to the PBX App Center->Upload page (Installation step same as step a)
2. Set the sip trunk number as the DOD number, the DOD number format should be '+(Country Code)(Area Code)(Number)'. Then set the SIP trunk 'Outbound Parameters->P Asserted Identity' with DOD Number.
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