Fanvil IP Phone Shows Internal Error after Provisioning by PBX Version X.13.0.30

Applicability

 

Symptom

After the Fanvil IP phone provisioned by PBX version X.13.0.30. The line shows registered, but when you make calls, the IP phone displays "Internal Error". 

 

Cause

It is an uaCSTA compatibility issue.

When the server type on Fanvil is set to "Common" and uaCSTA is activated, it requires to register 2 same accounts for use. 1 for the uaCSTA packets, the other account for the call.

However, when doing provisioning, the user would only register 1 account for use, and the uaCSTA is enabled when the phones are provisioned by the new firmware version. And then the problem could happen.

 

Solution

Firstly upgrade the PBX firmware to version X.13.0.34. Then do:

 

1. Upgrade the Fanvil Phone Firmware which supports CTI. 

1.1 You can upload the firmware to PBX. After upload, re-provision the Fanvil phones to perform the firmware upgrade.

mceclip0.png

1.2 Or you can manually upload the firmware to Fanvil Phone via its web interface.

Fanvil new firmware to fix the issue:

X4U: http://download.fanvil.com/Firmware/Release/X4U/2020-05-12/x4u-6902-P0.18.21-2.0.5-3305T2020-05-09-19.35.37.z 
X5U: http://download.fanvil.com/Firmware/Release/X5U/2020-05-12/x5u-6906-P0.18.21-2.0.5-3305T2020-05-09-19.48.37.z 
X6U: http://download.fanvil.com/Firmware/Release/X6U/2020-05-12/x6u-6915-P0.18.21-2.0.5-3305T2020-05-09-19.24.57.z 
X5S: http://download.fanvil.com/Firmware/Release/X5S/2020-05-12/x5s-6900-P0.18.21-2.0.5-3303T2020-05-13-15.50.25.z 
X6: http://download.fanvil.com/Firmware/Release/X6/2020-05-12-128M/x6-6914-P0.18.21-2.0.5-3305T2020-05-09-19.58.14.z 
X7: http://download.fanvil.com/Firmware/Release/X7/2020-05-20/x7-6926-P0.18.21-2.0.5-3845T2020-05-09-20.38.45.z 
X7C: http://download.fanvil.com/Firmware/Release/X7C/2020-05-12/x7c-6925-P0.18.21-2.0.5-3845T2020-05-09-20.46.45.z 
X210: http://download.fanvil.com/Firmware/Release/X210/2020-05-12/x210-6924-P0.18.21-2.0.5-3305T2020-05-09-20.10.28.z 
X210i: http://download.fanvil.com/Firmware/Release/X210i/2020-05-12/x210i-6923-P0.18.21-2.0.5-3303T2020-05-13-11.11.16.z 

Other models would be added soon (You might refer to solution 2 first).

 

2. Disable unCSTA option.

If you don't want to upgrade Fanvil IP phone firmware or the model has not been supported with CT. You can try to disable the uaCSTA option.

 

2.1 Disable the uaCSTA option by Auto Provisioning (Recommended)

  • Select the phone you need to disable the uaCSTA option. 
  • Go to the Feature tab. Untick the option "Enable uaCSTA". If it is already unticked, go to the next step directly.
  • Save the change and reboot the IP phone. (For CloudPBX, you need to reset the phone to perform the provisioning.)

mceclip2.png

For those models: X1/X1P, X1S/X1SP, X1SG, X2P, X2C, X3S/X3SP/X3G, X3SG, X3U, X4/X4G you need to additionally leave the uaCSTA Number field blank.  You can upgrade the  AutoProvisioning App to this version: http://help.yeastar.com/download/support/autoprovision-s_series-1.8.28.1.tar  (For S-Series only. If you are using cloud PBX, try to refer to the manual method in the following section.)

The version help remove the uaCSTA Number by default when you disable uaCSTA option.

mceclip0.png

Note that it requires to clean browser cache after the upgrade. So that you can view the new options in Auto-Provisioning App correctly.

 

2.2 Manually disable the uaCSTA on Fanvil IP phone.

This way applies to the situation when you manually register to PBX.

mceclip0.png

For those models: X1/X1P, X1S/X1SP, X1SG, X2P, X2C, X3S/X3SP/X3G, X3SG, X3U, X4/X4G you need additionally remove the uaCSTA Number as the following figure shows.

mceclip0.png

 

Have more questions? Submit a request

14 Comments

  • 0
    Avatar

    The proposed solution solved the problem regarding FANVIL telephones, but some problems remain on CISCO and ESCENE telephones

    Edited by fabrizio.guerra
  • 0
    Avatar

    Hi Fabrizio, what's the problem for Cisco? The upgrade this time doesn't involve Cisco and Escene.

    Could you specify the problem? Or you might submit a ticket to our support. Thanks.

  • 0
    Avatar

    Hello dear Pixy

    below are the problems I encountered with CISCO and ESCENE phones.

    Phone side, I see the registered sip account.
    Pbx side, inside the MONITOR PBX section, the phone is not registered.
    If I make an internal call, the ringing tone is heard but in fact the phone does not ring.
    Furthermore, on CISCO the registration takes place intermittently.
    If you need I can provide you with the web interface for both pbx and trlefones.
    Thanks for the support.

  • 0
    Avatar

    Ciao fabrizio il tuo nome mi ricorda l'italia!!!

    Now it's better that I try to speak in "English"
    I had the same problem with Fanvil X3G telephones and I only temporarily solved this by removing the extension number from the uaCSTA phone number.
    I don't know if it can be useful.
    bye, see you soon

     

  • 0
    Avatar

  • 0
    Avatar

    Ciao Gastone, ma sei il cugino di Alberto di Spilimbergo? Chiamami 366 2395978

  • 0
    Avatar

    Certamente

  • 0
    Avatar

    Chi potevo essere !!!

  • 0
    Avatar

    Hi There, solution updated in this article. Try to review the solution again:

    1. PBX firmware released with uaCSTA option added on the AutoProvisioning menu.

    Also includes the fix for the other issue related with Fanvil Video phone: https://support.yeastar.com/hc/en-us/articles/360048285793-Fanvil-Video-Phone-Call-Hangup-Immediately-when-Answered-after-PBX-Upgraded-to-X-13-0-30 

    2. Fanvil Phone firmware 2.0.5 download link added. This version improve the uaCSTA feature to prevent the  internal error.

  • 0
    Avatar

    Updating to 30.13.0.34 and disabling the new uaCSTA function didn't help. There is no new firmware for the X4G phones we are using.

    The solution provided by Gastone fixed the issue for me. Line > Advanced Settings > remove the uaCSTA  number:

    Thank you very much, Gastone!

  • 0
    Avatar

    Hi There,

     

    The old models X1/X1P,X2P, X2C, X3S/X3SP/X3G, X4/X4G would still have the Internal Error problem even after PBX was upgraded to version 30.13.0.34.

    Please try to upgrade the AutoProvisioning App to this version: http://help.yeastar.com/download/support/autoprovision-s_series-1.8.28.1.tar (It has already been updated in the article.)

     

    by way, thanks to Raffael

     

     

  • 0
    Avatar

    Guys Thanks lohit from botswana had the same issue but worked out after upgrading the autoprovision app

  • 0
    Avatar

    Dear sirs,
    we still have some issues with language on Fanvil X3S autoprovisioned, we have connected to ssh with support to check differences between autoconfigs:
    (For a correct display html tags have been replaced with "-")

    - Example of "WRONG" auto provisioned config (first 24 lines):

    /* AUTOGENERATED CONFIG that shows english menu*/
    cat 0c383e025e9b.cfg| head -n 24
    -?xml version="1.0" encoding="UTF-8"?-
    -VOIP_CONFIG_FILE-
    -version-2.0002-/version-

    -GLOBAL_CONFIG_MODULE-

    -SNTP_Server-ntp1.ien.it-/SNTP_Server-
    -Second_SNTP_Server-ntp2.ien.it-/Second_SNTP_Server-
    -Time_Zone-4-/Time_Zone-
    -Location-13-/Location-
    -Enable_DST-1-/Enable_DST-
    -DST_Fixed_Type-1-/DST_Fixed_Type-
    -DST_Min_Offset--/DST_Min_Offset-
    -DST_Start_Mon-1-/DST_Start_Mon-
    -DST_Start_Week--/DST_Start_Week-
    -DST_Start_Wday-1-/DST_Start_Wday-
    -DST_Start_Hour-1-/DST_Start_Hour-
    -DST_End_Mon-12-/DST_End_Mon-
    -DST_End_Week--/DST_End_Week-
    -DST_End_Wday-21-/DST_End_Wday-
    -DST_End_Hour-23-/DST_End_Hour-
    -Language-it-/Language-
    -/GLOBAL_CONFIG_MODULE-

    - Example of "good" manually modified config (first 24 lines):

    /* MANUALLY EDITED CONFIG that shows italian menu*/
    cat 0c383e025e9b.cfg| head -n 24
    -?xml version="1.0" encoding="UTF-8"?-
    -VOIP_CONFIG_FILE-
    -version-2.0002-/version-

    -GLOBAL_CONFIG_MODULE-

    -SNTP_Server-ntp1.ien.it-/SNTP_Server-
    -Second_SNTP_Server-ntp2.ien.it-/Second_SNTP_Server-
    -Time_Zone-4-/Time_Zone-
    -Location-13-/Location-
    -Enable_DST-1-/Enable_DST-
    -DST_Fixed_Type-1-/DST_Fixed_Type-
    -DST_Min_Offset--/DST_Min_Offset-
    -DST_Start_Mon-1-/DST_Start_Mon-
    -DST_Start_Week--/DST_Start_Week-
    -DST_Start_Wday-1-/DST_Start_Wday-
    -DST_Start_Hour-1-/DST_Start_Hour-
    -DST_End_Mon-12-/DST_End_Mon-
    -DST_End_Week--/DST_End_Week-
    -DST_End_Wday-21-/DST_End_Wday-
    -DST_End_Hour-23-/DST_End_Hour-
    -Language-7-/Language-
    -/GLOBAL_CONFIG_MODULE-

    So it seems that:

    -Language-it-/Language- [is wrong and shows english language which is index "0" ]

    -Language-7-/Language- [is right and shows italian language which is index "7" ]
    This happens with "Auto Provisioning Local Version: 1.8.28.1" and Firmware version .34

    Edited by Grassetti Gastone
  • 0
    Avatar

    Hello Pixy,

    I have a problem with Fanvil X6 FW: 2.2.1 on S50 with current FW.
    Autoprov. works , if an outgoing telephone call is finished, I can only set up a new outgoing call after 3 minutes.

Please sign in to leave a comment.